1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SSD freezing / pausing issue - How to fix it if you are using Intel LPM feature (we hope!)

Discussion in 'Computer Hardware' started by Shaun, 28 Mar 2012.

  1. Shaun

    Shaun Founder Staff Member

    If you're experiencing pausing / freezing issues with your SSD it could be due to Intel's LPM feature.

    One possible fix is the registry edit below.

    NOTE: This only works if you are using the Intel RST drivers. If you are using the default MS AHCI drivers, this will not work.

    Please follow these instructions at your own risk! As with any registry editing, serious issues can arise if you somehow mess things up, so we reccommend you take a backup first. Be careful!

    1) Copy the text in quotes below and paste it into a notepad file. Save the file as LPM.reg

    2) Go to the LPM.reg file location and double-click the file to execute it (this will inject the new registry settings).

    3) Restart your machine.

    This will disable the LPM only for Port 0 - which will allow the SSD to operate without freezes (we hope!) as well as allow your other hard drives to still use LPM. If your SSD is NOT on Port0, edit the file to have it disable LPM on whichever port your SSD is connected to.

    Code:
    Windows Registry Editor Version 5.00
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\iaStor\Parameters\Port0]
    "LPM"=dword:00000000
    "LPMDSTATE"=dword:00000000
    "DIPM"=dword:00000000
    
  2. amusicsite

    amusicsite dn ʎɐʍ sᴉɥ┴ Staff Member

    Location:
    UK
    Advert
    Makes me think I am right to wait a few more years for SSD's to stabilise and the software/hardware to work well together. I'll stick with my RAID-0
  3. Shaun

    Shaun Founder Staff Member

    I've just tried this on my works PC (that's the only one I've had any trouble with) and it's worked a treat. Turns out an auto-update of the drivers were the problem. :thumbsup: